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The purpose of this manual is to guide users on how to process ALOS-1 PALSAR-1 and ALOS-2 PALSAR-2 25-

meter mosaic datasets using a mixture of commercial and open source software. The initial goal was to do the entire 

process in open source software only. However, due to limited time, it was not possible if the processes done in 

ArcMap and ENVI could also be done using open source software. It is possible that most of these processes can 

be done in QGIS using additional plug-ins, but this will have to be explored further. 

The vision of the author was to prepare a process that would enable users to replicate the entire procedure for their 

own areas of interest and to enable the Forest Management Bureau (FMB) of the Department of Environment and 

Natural Resources (DENR) to generate their own forest cover and forest cover change maps using only freely 

available data such as cloud free radar data and Google Earth images. 

The majority of the pre-processing and some other repetitive steps have been automated and require very minor 

inputs from the user. The aspiration of the author was to automate the entire process but some steps involving 

ENVI and Excel spreadsheets are yet to be automated. The most tedious part of the entire process is the selection 

of samples from Google Earth and this could also be the major challenge of the procedure especially if no high-

resolution satellite images and/or aerial photographs are available. 

A separate technical report entitled “Forest Cover and Change Classification using ALOS PALSAR Mosaic Data 

and Decision Tree Classifiers” (Estomata 2017), on the technical and scientific background of the methodologies 

applied in this work was also prepared. 

The first manual, ALOS PALSAR 25-meter Mosaic Step-by-step Manual on Extraction of Forest Cover and Change 

Detection (Estomata 2014) was published in 2014 manual did not involve automation. The classification algorithms 

explored in the 2014 step-by-step manual were traditional supervised classification algorithms found in ENVI. 

In this manual, decision tree classification was explored instead and direct classification to detect change was also 

tested. All maps generated went through unbiased area estimation in order to achieve bias free estimates of forest 

and deforestation areas as well as measures of uncertainties. 

At the begging of this manual, a quick overview of what data, software and skills/experience are needed from the 

user. All scripts written in Python and R language as well as the spreadsheets are provided to guide users on how to 

prepare the data to be used in the processes and enable them to replicate the entire procedure. 

A process workflow is presented at the beginning of each Chapter in order to guide users on what processes to 

expect in every Chapter. The first chapter shows the steps how to produce a georeferenced radar image while the 

second chapter elaborates how to obtain training and accuracy assessment samples from existing land cover maps, 

field data and Google Earth images.  

The third chapter discusses the steps how to integrate the outputs of the first two chapters in order to achieve 

thresholds to be used for decision tree classification. The process of accuracy assessment and unbiased area 

estimation is shown in the same chapter.  

The fourth chapter discusses how to generate the radar image to be used for the direct classification of change. In 

this chapter, users are given insights on how to select samples of deforestation based on the acquisition dates of the 

radar images and these samples are used to determine thresholds for the decision tree classification discussed in the 

last chapter.  

The author would like to give her utmost gratitude to the reviewers of this manual Engr. Don De Alban of the 

National University of Singapore and Ms. Patricia Sanchez of the Forest Management Bureau. Without their inputs, 

this manual would not have been as detailed as it is now. 
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The main datasets used in this manual are the ALOS-1 PALSAR-1 and ALOS-2 PALSAR-2 25-meter mosaic data. 

Landsat images were used for georeferencing the pre-processed PALSAR-1/2 images. The 2010 Land Cover Map of 

the Philippines from the National Mapping and Resource Information Authority (NAMRIA) and field data from the 

Forest Resources Assessment (FRA) of the National REDD+ System Philippines project were also utilized as 

training and accuracy assessment samples. 

ALOS-1/2 PALSAR-1/2 25-meter mosaic 
The radar remote sensing data used during the development of this work were acquired using the active microwave 

sensor called the Phased Array type L-band Synthetic Aperture Radar (PALSAR). 

The 2007-2010 images were acquired by PALSAR-1 aboard the non-operational Advanced Land Observing Satellite 

(ALOS-1) (Rosenqvist et al. 2004) and the 2015 images were acquired by the PALSAR-2 aboard the operational 

ALOS-2 (ALOS-2 Project Team 2014). 

The 25-meter mosaic datasets are freely downloadable from Earth Observation Research Center (EORC) of the 

Japan Aerospace Exploration Agency (JAXA) website. A guide on how to access the data is found in (Annex 1). 

A complete coverage of the Philippines for the years 2007-2010 and 2015-2016 is currently available on the website. 

The 2016 mosaic product was not yet released during the development of this work and was therefore not included 

in the processing. 

Landsat  
Landsat 7 ETM+ data were used to register the PALSAR-1/2 images. Further explanation why this step was done is 

elaborated in Estomata (2017). The Landsat data can be downloaded from USGS’s EarthExplorer 

(http://earthexplorer.usgs.gov/) and a step-by-step procedure how to download Landsat data may be found in the 

first step-by-step manual published in 2014 (Estomata 2014). 

2010 Land cover map of the Philippines 
The 2010 Land Cover Map of the Philippines was generated by the National Mapping and Resource Information 

Authority (NAMRIA). The files were utilized in Shapefile (.shp) format. As of the writing of this manual, the 2015 

Land Cover Map of the Philippines also produced by NAMRIA had not been released. For a short description of 

the 14 classes of the land cover map, a copy of the Department Memorandum Circular (DMC) 2005-05 is provided 

at the end of this manual. 

Field data 
The field data used in this work were from the Forest Resources Assessment (FRA) of the REDD+ project. The 

data were exported from a database software to a spreadsheet. Latitude and longitude information from the FRA 

were used to display the data in the geographic information system (GIS) software. For the complete details of the 

methodology of the FRA please refer to (Lennertz et al. 2017). 

  

http://earthexplorer.usgs.gov/
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The main computer used for the data processing and the steps described in this manual was a 64-bit Windows 7 HP 

desktop computer (Compaq Elite 8300 Small Form Factor) with a Core i7-3770 CPU @ 3.40 GHz processor and 

16.0 GB RAM. 

During a replication and testing process of the manual, two laptops were used to process the same dataset and apply 

the steps from this manual. The laptops were as follows: 

Brand Toshiba Lenovo 

Model Satellite P50-A X240 

Operating System Windows 7 Windows 10 

System type 64-bit, x64-based processor 64-bit, x64-based processor 

Processor Core i7-4700MQ CPU @ 2.40 GHz Core i5 of CPU @ 1.60 GHz 

RAM 8.00 GB 4.00 GB 

 

The Toshiba laptop had half the RAM of the main computer used by the author and was able to successfully run all 

the processes described in this manual, but it was much slower than the HP desktop computer. 

The Lenovo laptop, which had half the power of the Toshiba laptop, was not able to perform most of the 

processing. When, for example, Python codes with batch processing was run in XUbuntu_RSGISLib, early 

termination of the codes occurred. 

Therefore, the recommended minimum specifications for a computer/laptop should be: RAM of 8.00 GB with a 

Core i7 @ 2.40 GHz processor. Anything lower than these specifications may lead to unsuccessful processing of 

the datasets especially in the batch processing done in XUbuntu_RSGISLib. 

The author is uncertain if the version of Windows (Windows 7 or Windows 10) was a factor contributing to the 

success of data processing. However, during trainings with JAXA, it was found that 32-bit computers won’t be able 

to run RSGISLib, therefore, a 64-bit Operating System is required. 
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Nine different software applications were used to apply the processing steps found in this manual. Two of which are 

commercially available, while the rest are free and/or open-source.  

1. ENVI 5.x (Environment for Visualizing Images) is a commercial software application that can be used for 

processing and analyzing geospatial imageries. In this manual, ENVI was used to apply image to image 

registration, ROI separability analysis, the decision tree classification and post-classification procedures. 

http://www.harrisgeospatial.com/ProductsandTechnology/Software/ENVI.aspx 

2. ESRI ® ArcMap ™ 10.2 (with spatial analysis extension) is a proprietary commercial software that is a 

geographic information system (GIS). It was used for most of the GIS processes such as aggregation of classes, 

cropping, buffering and cross-checking of samples. It was also used to generate the final maps found at the end 

of the technical report (Estomata 2017). https://www.arcgis.com/features/index.html 

3. QGIS was previously known as Quantum GIS. It works on all platforms/operating systems and is an open-

source GIS application that is similar to ArcMap/ArcGIS. http://www.qgis.org/en/site/ 

4. Google Earth Pro used to be a commercial geospatial software application that costs 399USD per year. It is a 

geobrowser (also known as ‘virtual globes’ or ‘Earth browsers’) that can access all kinds of data (satellite/aerial 

imageries, bathymetry, geographic data, etc.) over the internet and uses all these data to represent the Earth as a 

3D globe. https://www.google.com/earth/desktop/ 

5. SNAP tool (Sentinel Application Platform) is an open source software application developed by the European 

Space Agency (ESA). It can be used for processing and analyzing Earth Observation/geospatial imageries but 

especially useful for processing radar images. In this manual, it was utilized only for the multiple speckle 

filtering step of the radar images. http://step.esa.int/main/toolboxes/snap/ 

6. Oracle VM VirtualBox is a free and open-source ‘hypervisor’ or ‘virtual machine monitor’ (VMM) for 32-bit 

computers. It can be installed in a number of host operating systems such as Linux, macOS, Windows, Solaris, 

and OpenSolaris. This virtualization application allows users to install other operating systems on a computer 

with an existing Intel or AMD-based operating system. A computer where a hypervisor runs one or more 

virtual machines is a “host machine” and each ‘virtual machine’ is called a “guest machine.” 

https://www.virtualbox.org/ 

7. RSGISLib (Remote Sensing and GIS Software Library) is a collection of tools that can be used to process 

remote sensing and GIS datasets. The tools can be accessed using Python bindings, which made it possible to 

automate the majority of the pre-processing steps found in this manual. The tedious task of generating zonal 

statistical information was also automated using this software. http://www.rsgislib.org/ 

8. RStudio is an integrated development environment (IDE) for R, which is a programming language used for 

statistical computing and graphics. It is available in commercial and open-source editions and can work in 

Windows, macOS or Linux. https://www.rstudio.com/ 

9. MS Excel is a commercial spreadsheet application developed by Microsoft. Any spreadsheet application can 

also be used such as Open Office Calc. https://products.office.com/en/excel and 

https://www.openoffice.org/ 

  

http://www.harrisgeospatial.com/ProductsandTechnology/Software/ENVI.aspx
https://www.arcgis.com/features/index.html
http://www.qgis.org/en/site/
https://www.google.com/earth/desktop/
http://step.esa.int/main/toolboxes/snap/
https://www.virtualbox.org/
http://www.rsgislib.org/
https://www.rstudio.com/
https://products.office.com/en/excel
https://www.openoffice.org/




Skills and experience requirements





 
    

 
10 

 
 

It is assumed that the user of this manual is familiar with Remote Sensing (RS) and GIS concepts. It is a great 

advantage if he/she is familiar with the commercial software ArcMap and ENVI and the free software Google 

Earth Pro and QGIS. The following table shows the skill/familiarity level recommended to be able to effectively 

and efficiently use the different software needed in this manual. 

Skill/Familiarity Requirement High Fair Low 

RS and GIS concepts x   
ENVI, ArcMap, Google Earth Pro x   

QGIS  x  
SNAP   x 
Oracle VM VirtualBox  x  
RSGISLib and Python  x  
RStudio and R   x 
Spreadsheets   x 

 

Familiarity with using a virtual machine (Oracle VM VirtualBox) will help the user to easily go through the steps that 

alter between a host machine with an operating system of Windows 7 and an Ubuntu virtual machine. It is highly 

recommended to be familiar with RSGISLib using the introduction training from the RSGISLib website.1 

Information on how to install the Xubuntu_RSGISLib open virtualization application/appliance (OVA) may also be 

found in the same link. It is recommended to install this correctly before the user begins any processing. 

Although most of the Python scripts prepared and run on the virtual machine will require minimal editing (changing 

only the input and output filenames), the user may opt to learn Python scripting using the e-book by Downey et al. 

(2002). 

Minimal knowledge for RStudio and R language is needed unless the user intends to tweak the R scripts to his/her 

purpose. Very little skill is also required to use ESA’s SNAP tool as only speckle filtering is done in this software. 

The same is true with the skills required for using spreadsheets, as all the calculations and formatting have already 

been prepared. 

  

                                                           
1 http://rsgislib.org/documentation.html#rsgislib-introduction-training 

http://rsgislib.org/documentation.html#rsgislib-introduction-training
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The Python scripts, R scripts and formatted spreadsheets are provided to facilitate the replication of the processes 

elaborated in this manual. 

Python scripts 
There are seven folders containing Python scripts that will be executed inside Xubuntu_RSGISLib via Oracle VM 

VirtualBox. The folders are as follows: 

1. Prep_SpeckleFilter  automatically prepares the radar files needed for multi-temporal speckle filtering 

2. Separate_Bands  automatically separates the bands of the multi-temporal speckle filtering results (produced 

by SNAP) into individual bands 

3. Preprocessing  automates the pre-processing of the radar data to prepare it for image analysis 

4. ZonalStat  automatically calculates the statistics of the radar images within sample Regions of Interests 

(ROIs) 

5. computeDate_ALOS  provides the dates of acquisition of the radar images after the user provides the 

digital number (DN) values from the acquisition date files 

6. ChangeImages two scripts that automatically calculate the area between year1 and year2: 1) difference 

change index (DCI) image and 2) the combined radar effects mask  

7. DCI_ZonalStat  calculates the statistics of the DCI image within sample ROIs. 

R-scripts 
There are three R scripts. One that makes boxplots, another that identifies thresholds for the forest cover maps and 

another one that identifies the thresholds for the forest cover change maps. 

Formatted spreadsheets 
Five pre-formatted spreadsheets are provided and will do the following: 

• Consolidate the statistics of forest cover and forest cover change in two separate comma-separated values (CSV) 

files. These will be inputs to the R scripts. 

• Generate random numbers2 from 1 to the total number of available samples, with no repetitions. This is used 

for the selection of training and accuracy assessment samples. 

• Determine the number of accuracy assessment samples required to achieve a certain confidence level. 

• Apply unbiased area estimation. 

  

                                                           
2 http://www.excelbanter.com/showthread.php?t=6006 

http://www.excelbanter.com/showthread.php?t=6006
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This manual is based on the methodology discussed in the report “Forest Cover and Change Classification using 

ALOS PALSAR Mosaic Data and Decision Tree Classifiers” (Estomata 2017). The workflow shown in the 

flowchart below presents the different processes used in the methodology and in this manual. Each chapter covers 

one general process (GP), including all the sub-steps as illustrated in Chart 1 of Annex 5. 

  





A. Data  preparation and 
pre-processing of radar 
remote sensing data
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The first GP requires PALSAR-1/2 mosaic files for all years available (2007, 2008, 2009, 2010 and 2015) for each 

area of interest (AOI). The final products of GP1 are georeferenced PALSAR-1/2 files for 2007, 2010, and 2015 

containing multi-temporal speckle filtered polarization bands and additional band ratios. The complete flow of the 

processes and additional details of some steps are found in Chart 2 of Annex 5. 

A.1 Data export 
• Data required: Compressed (‘.tar.gz’) PALSAR-1/2 25-meter mosaic files for all years available (i.e. 2007-2010 

and 2015) for the area of interest (AOI) (i.e. Davao Oriental). 

• Software: Any operating system that can extract compressed files (i.e. Windows 7). 

• Purpose: Compressed files cannot be processed by the software. 

 

1. After downloading the compressed files, extract them all to one folder. 

2. Select only the HH and HV files of each year. Do not forget to include their respective header (.hdr) files.  

 

3. Prepare Xubuntu_RSGISLib (refer to next section). 

A.2 Transfer of files to RSGISLib 
• Data required: Uncompressed HH and HV files for all years available (files selected in A.1) 

• Software: 

o Host operating system (i.e. Windows 7)  

o Xubuntu_RSGISLib via Oracle VM VirtualBox 

• Purpose: An automated procedure is available only on RSGISLib. 

 

1. Right click the Oracle VM VirtualBox software in your host operating system (Windows 7) and click on the 

Xubuntu_RSGISLib.ova. Wait for it to load and run.  

If you have not installed the RSGISLib open virtualization application/appliance (OVA), please refer to 

Annex 2. 
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2. Make sure that the Drag’n’Drop option of the VirtualBox is allowed. Set it to ‘Bidirectional’ so files can be 

moved from the Host operating system (Windows 7) to the Guest operating system (Ubuntu) and vice versa. 

 

3. Click and drag the selected HH and HV files (step 2 of A.1) to the Desktop of the VirtualBox. Take note of 

the folder location containing all the extracted files in section A.1. This will be needed in section A.6.  
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4. The files should all appear on the Desktop of the VirtualBox. Maximize the VirtualBox window by clicking on 

the maximize button  to see if all the files are on the Desktop. 
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5. If the drag and drop method does not work, copy the files (HH and HV files plus the Python scripts) to a 

USB stick instead within your Windows OS. 

 

6. After copying the files within Windows, connect the USB to your VirtualBox by clicking on Devices > USB > 

Your_USB… 

 

 

7. This should mount your USB on the VirtualBox. Copy the files (HH and HV files plus the Python scripts) 

from your USB to your VirtualBox. 

8. Do not close the VirtualBox and proceed to the next section. 

 

A.3 Preparation of files for multi-temporal speckle filtering 
• Data required: Uncompressed HH and HV files for all years available inside Xubuntu_RSGISLib (as 

described by steps of A.2) 

• Python script(s): Scripts found in “prep_SpeckleFilter” folder 

• Software: Xubuntu_RSGISLib via Oracle VM VirtualBox 

• Purpose: A specific format of the files is required for the multi-temporal speckle filtering and will be generated 

in this step. 
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1. Continuing from the previous section, move the files (must be 20 files in total for this example) to the folder 

containing the Python scripts found in the prep_SpeckleFilter folder.  

 

2. Inspect the Python scripts to make sure that the files being called in the scripts correspond to the files present 

in the same folder. This happens inside the 1_translate.py script. To open it, double click on the file.  

3. The dataset being opened in the script should match the name of the files found in the same folder that 

the script is saved under. 
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If it does not match, change the filenames found in the script to match the files in the folder. Save the script 

and close the gedit window.  

 

4. Check the last Python script 3_translate.py. The output GeoTIFF file should refer to the files that you are 

processing (i.e. Davao Oriental years 2007-2015). 

 

If it is not, change it by editing the Python script as was done in Step 3. Save the script and close the gedit 

window.  
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5. On the task bar, click on run the Terminal Emulator.  

 

6. A blank Terminal window will appear. 

 

7. In the Terminal, navigate to the folder where the Python scripts and files are located (refer to Step 1 for the 

folder location). 

Some useful commands for the terminal are the following: 

o “ls” – to get a list of files in your current directory 

o “cd” – to change your current directory (i.e. “cd Desktop” to move to the Desktop folder) 

o “cd ..” (two periods after ‘cd’) – to return to the previous directory 

o “python python_script.py” – to run any python script found in the current directory 

 

8. Run the 0_run.py script using the command on the terminal ‘python 0_run.py’. 

 

The 0_run.py is a batch script that automatically runs the other 3 python scripts which will do the following: 

• 1_translate.py  convert the files into KEA formatted files, which are processed faster by RSGISLib. 

• 2_stack_bands.py  stack all the KEA files into a single KEA file. 

• 3_translate.py  convert the stacked KEA files into a GeoTIFF file format, which is accepted by the 

SNAP tool.  
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9. The Python scripts will automatically delete temporary files in order to save space and will only save the 

original HH and HV files along with their respective header files. 

 

The output of the Python script (TIFF file) will also be found in the same folder. 

 

10. Select the new TIFF file and drag and drop it in your host OS (i.e. Windows). 

 

If drag and drop does not work, connect a USB to the VirtualBox (see step 6 of A.2) and copy-paste the 

files to the USB stick. After moving the files to the USB, unmount the USB from the VirtualBox by 

repeating the “mounting” procedure. 

 

The USB stick should be unmounted from the VirtualBox and will appear on your host operating system (i.e. 

Windows). 

 

11. Close the VirtualBox to free up memory that may be needed for the next section. 

Final output: A TIFF file composed of all HH and HV mosaic scene bands of an AOI. If an AOI has mosaic scenes 

from years 2007 to 2010 and 2015 only, then there will be 10 bands available in the TIFF file. 
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A.4 Multi-temporal speckle filtering 
• Data required: GeoTIFF file generated from A.3. 

• Software: SNAP 

• Purpose: To generate a multi-temporal speckle filtered version of the input file. 

 

1. Run the SNAP software and import the GeoTIFF generated from A.3 by selecting File > Generic Formats 

> GeoTIFF. 

 

2. Navigate to where the GeoTIFF file from A.3 was saved. Select the file and click Import Product.  
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3. The file will appear on the Product Explorer portion of the SNAP window. Click on the “+” signs on the left side 

of the filenames to expand the data.  

 

4. Prepare the data for multi-temporal speckle filtering. Right click on each band and click Properties. 

 

5. Change the Unit to “amplitude” and the Product name as follows: 

 

o band_1  HH_07 

o band_2  HV_07 

o band_3  HH_08 

o band_4  HV_08 

o band_5  HH_09 

o band_6  HV_09 

o band_7  HH_10 

o band_8  HV_10 

o band_9  HH_15 

o band_10  HV_15 

 

Note that this is based on how the bands were assigned in Step 3 of A.3. If you have altered the 

arrangement in that step, this step will have to follow your arrangement so that the bands are labeled 

accordingly. 

  



 
    

 
26 

 
 

 

6. Repeat steps 4 and 5 for each band until they have all been renamed and all have the unit “amplitude”. 

 

7. Click on the Menu Bar: Radar > Speckle Filtering > Multi-temporal Speckle Filter. 
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8. The Multi-temporal Speckle Filter window will appear. 

 

Give the target product a filename. 

 

Change the Save as: format from BEAM to GeoTIFF so it can be recognized later by the Python scripts. 

 

Select the folder where the file should be saved. 

 

Do not click the Run button yet. 

 

9. Click on the Processing Parameters tab. 

 

Select all available bands as Source Bands and leave the settings at default. 
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Click the Run button. 

 

10. The Writing Target Product window will appear. 

 

If an error occurs, the data preparation of the bands (Steps 4-6) may have been incorrect. Please double check 

and make sure that the unit of all the bands was changed to “amplitude”.  

 

When the process finishes, the Writing Target Product window will automatically close and the Multi-temporal 

Speckle Filter window will re-appear. 
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11. It will report in red font the time it took to accomplish the process (i.e. 5.75 mins). Click ‘Close’ to close this 

window. 

 

12. Scroll through the Product Explorer and find the new product generated by the previous step.  
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13. To view the multi-temporal speckle filtered bands and compare them with the bands of the original file, right 

click on a band from one file (i.e. old file) and click Open Image Window.  

 

14. A navigation pane window will appear below the Product Explorer and an image will appear on the image viewer 

on the right side of the Product Explorer.  

 

Click inside the navigator to move around the image and click on the zoom button to zoom in an area to 

be viewed in the image viewer. 

 

15. Repeat Step 13 for the other image (i.e. new file and same band as in Step 13). Zoom in on the same area as 

in Step 14. Click on the tabs to view the images alternately.  

 

Note that the new image has less “noise” or “salt and pepper” effect. You may repeat these steps for all other 

bands of the images to see how the multi-temporal speckle filtering improved the images. 
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Final output: A TIFF file with all the speckle filtered HH and HV mosaic scene bands of an AOI. Since the 

input file had 10 bands, the output also has 10 bands. 

A.5 Separate the HH and HV bands into separate files 
• Data required: GeoTIFF containing the multi-temporal speckle filtered HH and HV bands (product of A.4) 

• Python script: Scripts found in “separate_bands” folder 

• Software: Xubuntu_RSGISLib via Oracle VM VirtualBox 

• Purpose: To automatically separate the 10 bands into individual bands. This process can also be manually done 

using ENVI. 

 

1. Right click the Oracle VM VirtualBox software in your host operating system (Windows 7) and click on the 

Xubuntu_RSGISLib.ova. Wait for it to load and run. 

2. Drag and drop the GeoTIFF file containing the multi-temporal speckle filtered HH and HV bands 

(product of A.4) to the Desktop of Xubuntu_RSGISLib.  

 

After it is copied into Xubuntu_RSGISLib, move the file to the folder containing the Python script 

4_MTF_separate_stack.py. 

 

3. Inspect the Python script to see if the input filename corresponds to the file found in the folder. To open 

the script, double click on the file. The dataset being opened in the script should match the name of the file 

found in the same folder that the script is saved in. 

 

If it does not match, change the filename in the script to match the file in the folder.  
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4. Save the script and close the gedit window.  
5. Open the Terminal Emulator and navigate to the folder where the GeoTIFF file and 

4_MTF_separate_stack.py scripts are located. 

 

Run the Python script by typing “python 4_MTF_separate_stack.py” in the Terminal window. 

 

6. The Python script will separate the files and convert the 2007, 2010, and 2015 HH and HV files to KEA format 

so that RSGISLib can process them faster. 

 

The original TIFF file is also automatically deleted in order to save space in the VirtualBox. 
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Final output: Separate KEA files for each speckle-filtered HH and HV band of the AOI for each year of interest 

(i.e. 2007, 2010, and 2015). 

A.6 Pre-processing 
• Data required:  

o HH and HV files in KEA format of 1 year (i.e. 2007) from A.5. 

o Uncompressed mask, incidence angle and acquisition date files for the same year as HH and HV files 

selected (i.e. 2007 also) 

• Python script: Scripts found in “Preprocessing” folder 

• Software: 

o Host operating system (i.e. Windows 7)  

o Xubuntu_RSGISLib via Oracle VM VirtualBox 

• Purpose: To automatically pre-process the bands available for a single year. This process can also be manually 

done using ENVI. 
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1. In the host operating system (Windows 7), navigate to where the compressed radar files were extracted. 

 

Select the mask, incidence angle and acquisition date files for the year of the HH and HV image that will 

be processed (i.e. 2007). Do not forget their respective header files. 

Copy the files into VirtualBox (similar to Step 3 of A.2). 

 

2. Move these new files in one folder including the corresponding HH and HV files produced in A.5. 

 

In the same folder, seven Python scripts (all scripts found in the Preprocessing folder) must be present as 

seen in the following image. 

 

3. Inspect the Python scripts to make sure that the files used and referred to in the scripts correspond to the 

files present in the same folder. This happens in the 1_translate.py script. To open it, double click on the file. 

 

The dataset being opened in the script should match the name of the files found in the same folder that the 

script is saved in. 

 

If it does not match, change the filenames found in the script to match the files in the folder. Save the script 

and close the gedit window. 

 

4. Check the last Python script 6_translate.py. The output GeoTIFF file should match the name of the files that 

you are processing. 

 

If it is not, change it by editing the Python script accordingly. Save the script and close the gedit window.  
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5. Run the Terminal Emulator and navigate to the folder where the files in Step 2 are located. 

 

Run the 0_run.py Python script by typing “python 0_run.py” in the Terminal window. This will run all the other 

6 scripts automatically. 

 

 1_translate.py  this will convert the mask, incidence angle and acquisition date files to KEA format. The 

HH and HV bands of a specific year (i.e. 2007) will also be given a generic name of “hh” and “hv” to ease 

the automation procedure. 

 2_stack_bands.py  this will stack the HH and HV files produced in A.5 in one file. 

 3_calibrate_data.py  this will convert the stacked version of the HH and HV to radar cross section values 

with decibel (dB) units 

 4_maskband.py  this will convert the mask band to a binary mask with values of 0 and 1 

 5_ratios.py  this will calculate five additional ratios – HH/HV, HV/HH, HH&HV average, NDI and NL 

(discussed in the technical report (Estomata, 2017)). 

The mask generated by the previous script is also applied on radar-cross section bands generated by the 

calibrate script and on the five additional ratios. These masked bands, masked ratios, the KEA files of the 

mask, incidence angle and acquisition date files (produced by the first translate script) are stacked in a 

single file. This file will have 10 bands in total. 

 6_translate.py  this script will just convert the final stacked file into a GeoTIFF file.  
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6. Copy the new file to your host operating system (Windows), where your ENVI software is installed (refer to 

Step 10 of A.3).  

7. Close the VirtualBox to free up memory that may be needed for the next section. 

 

Final output: A TIFF file of an AOI of year 1 (i.e. 2007) with 10 bands. The bands that it is composed of are as 

follows: 

• Band 1 (HH) – is the HH band in radar cross section values 

• Band 2 (HV) – is the HV band in radar cross-section values 

• Band 3 (HHHV) – is the ratio HH/HV  

• Band 4 (HVHH) – is the ratio HV/HH  

• Band 5 (HHHVave) – is the ratio (HH+HV)/2 

• Band 6 (NL) – is the ratio (HH*HV)/(HH+HV) 

• Band 7 (NDI) – is the ratio (HH-HV)/(HH+HV) 

• Band 8 (mask) – is the re-calculated mask band  

• Band 9 (inci) – is the original incidence angle band 

• Band 10 (date) – is the acquisition date band of  

Note: Repeat the entire process for each mosaic scene of a different year and location (i.e. AOI#1 for 2010, AOI#1 

for 2015, AOI#2 for 2007, etc.). 

A.7 Registration to Landsat 7 
• Data required: 

o Stacked GeoTIFF file produced by A.6 

o Landsat 7 with minimal cloud cover 

• Software: ENVI 5.x (classic view) 

• Purpose: To improve the referencing of the PALSAR images. It has been observed that there is a discrepancy 

of features between PALSAR and Landsat images. 

 

1. Open ENVI 5.x (classic view). 

2. Open the stacked PALSAR GeoTIFF file (product of A.6) by clicking on File > Open Image File… 

 

The Enter Data Filenames window will appear. Navigate to the folder containing the stacked PALSAR 

GeoTIFF file. Select the file and click Open. 
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3. The file will appear in the Available Bands List window. The bands are as follows: 

a. Band 1 is HH 

b. Band 2 is HV 

c. Band 3 is HHHV 

d. Band 4 is HVHH 

e. Band 5 is HHHVave 

f. Band 6 is NL 

g. Band 7 is NDI 

h. Band 8 is mask 

i. Band 9 inci 

j. Band 10 is date 

 

4. Open the corresponding Landsat image (i.e. Davao Oriental PALSAR should be registered to a Landsat image 

of Davao Oriental also) by clicking on File > Open Image File from the Available Bands List window. 

 

Again, the Enter Data Filenames window will appear. Navigate to the folder where the Landsat dataset is 

located. 

  



 
    

 
38 

 
 

To open a stacked version of the Landsat 7 data, select the accompanying “_MTL” text file. After selecting 

that file, click Open. 

 

5. A stacked version of the Landsat data should appear in the Available Bands List window. If the stacked version of 

the Landsat file does not successfully open, repeat Step 4 and select all available bands, except the thermal 

bands (Band 6 – B6), and click Open. 

 

6. The 7 Landsat bands will appear as individual files in the Available Bands List window.  



 
    

 
39 

 
 

7. Load the images in Gray Scale or RGB Color, whichever you prefer. Good combinations of bands for the 

PALSAR and Landsat images are shown in the following table: 

Color PALSAR Landsat 

Red (R) Band 1 (HH) Band 5 

Green (G) Band 2 (HV) Band 4 

Blue (B) Band 3 (HH/HV) Band 3 
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8. Make sure to open the images in different displays so that both bands will appear side by side as shown in the 

following image. 

 

9. To start image registration, navigate to the Menu Bar and click Map > Registration > Select GCPs: Image 

to Image… 

 

10. The Image to Image Registration window will appear. 

 

For the Base Image, select the display that shows the Landsat image (i.e. Display #2), and for the Warp 

Image, select the stacked PALSAR-1/2 file (i.e. Display #1). 

 

After choosing the correct images, click OK.  
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11. The Ground Control Points Selection window will appear. 

 

12. To start the GCP selection, select a feature that is prominent in both PALSAR-1/2 and Landsat images. Once 

satisfied with the selected pair of points, click on Add Point. 

 

Make sure that the GCPs are well distributed across the image as much as possible. 
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13. Continue adding GCPs until there are 10–20 pairs that are well distributed all over the image. 

 

Note that once the number of GCPs reaches 5, the RMS Error will have a value. Note: Try your best to keep 

it below 1.00.  

 

14. Click on the Show List to make the Image to Image GCP List appear. On the last column, it will show the RMS 

for each GCP. The bigger the value, the bigger the error.  

 

Use this to adjust the location of the points to minimize the total RMS Error. 
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15. To illustrate how well distributed the points should be, refer to the following image. 

 

The more GCPs you can find, the better. 

 

Note that the RMSE is below 0.5. 

 

16. Once satisfied with the GCPs selected, navigate to Options > Warp File (as Image to Map)…  
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17. The Input Warp Image window will appear. Select the PALSAR image to be warped/georeferenced and click 

OK. 

 

18. The Registration Parameters window will appear as follows. These are default settings and will have to be 

configured to your preferences. 

 

 

19. The Projection and Datum should match the projection and datum of the Landsat image used for the 

registration.  

 

If the default setting does not match the projection and datum of Landsat, click on Change Proj… and select 

the appropriate project and datum 

 

20. Change the X and Y Pixel Size to 25, to retain the original size of the PALSAR-1/2 image. 

 

Make sure to hit the ENTER key after typing the number 25 so that the Output X & Y Size (pixels) will 

also change.  
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21. Click on the radio button File and click on Choose to select the desired save location. Supply a filename with 

the file extension “.tif” and then click on OK.  

 

The following image illustrates the difference in output results when the Enter key in Step 20 is hit (or not). If the 

Enter key is not hit, the Output X & Y Size will remain the size as shown in the left portion of the following image. 
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22. The Image Registration process window will appear. Wait for it to finish. 

 

When the process ends, the registered image (all 10 bands) will now appear in the Available Bands List window. 

 

23. Before closing the Ground Control Points Selection window, save the selected GCPs by clicking on File > Save 

GCPs to ASCII…  

 

24. The Output Registration Points window will appear. Click on Choose to select the desired save location. Supply a 

filename and then click on OK.  

 

25. The same GCPs can be used for the other years of the same AOI (i.e. mosaic scenes for years 2010 and 2015). 

 

Just make sure that the same Landsat image used in the first GCP selection is also the Landsat image 

used to register the new mosaic scenes.  

 

And also, before using the pre-determined GCPs, double check first if the points still correspond 

correctly to the new mosaic scenes.  

 

Final output: A georeferenced TIFF file of the output of A.6. 

Note: It is important to double check the results of your georeferencing by using the Geographic Link display of 

ENVI. Link both Landsat and the warped ALOS PALSAR images. 
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When you click a portion from either image, it should match the geographic location in the other image. To do this, 

right click on any of the images and select Geographic Link… The Geographic Link window will appear. Click on 

the  to turn the desired Displays from Off to On. 

 

Note: Repeat the entire process of Chapter A for a different AOI and use the appropriate Landsat images. 

  



B. ROI selection and pre-processing
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The process requires the shapefile of the 2010 National Land Cover Map from NAMRIA. To be compliant with the 

requirements of the Intergovernmental Panel on Climate Change (IPCC 2003), the initially 14 classes from the land 

cover map were aggregated to match the 6 IPCC classes.  

An additional class for Coconut Palm is also included as it is of interest to separate Coconut Palms from Forest. The 

FRA data from the field were also used as samples for Forest areas. 

The final product of GP2 are shapefiles of the different classes for training and accuracy assessment. To visualize 

the entire process applied in this chapter, please see Chart 3, Annex 5. 

B.1 Aggregation of classes of the land cover map 
• Data required: Shapefile for the 2010 National Land Cover Map 

• Software: ArcMap 

• Purpose: To simplify the 14 classes into 6 classes only 

 

1. Open ArcMap and click Add Data . 

2. Navigate to the folder containing the shapefile of the Land Cover of your area of interest (i.e. Davao Oriental). 

3. Merge the classes of the shapefile to follow the aggregation illustrated in the following image.  
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4. To merge the classes, right click on the shapefile in the Table of Contents and click on Open Attribute Table. 

 

 

5. To facilitate a faster selection of all the classes that are supposed to be merged, the Select By Attributes… will 

be used. Click on that option. 

 

6. The Select by Attributes window will appear. 

 

The syntax should be the name of the column containing the classes (i.e. “AGG14”) equal to a specific class 

name (i.e. “Grassland” or “Wooded Grassland”). 

 

So that either of the classes would be selected, the “OR” must be present between the two selections.  
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7. When Apply is clicked and the syntax provided is correct, the classes that match the syntax will be selected in 

the attribute table. 
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8. To merge, find the Editor on the Toolbar and click on Start Editing. After that, select again the Editor and 

click on Merge… 

 

9. The Merge window will appear. Select any feature found in the list. All the other features will merge with this 

selected item. 

 

The tool will keep the information of the selected feature and delete the rest after clicking OK.  

 

10. Repeat Steps 4 – 9 for the other classes  

 

Refer to the aggregation illustrated in Step 3 to determine the syntax for the other classes. You must have 6 or 7 

features left by the end of the merging process (1 per class). 

 

Replace the class name to match the names of the 6 IPCC and additional classes (refer to Step 3 again). 
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To edit the class name, double click on the cell and type the appropriate class name. 

 

11. After finalizing the edits, navigate to Editor > Stop Editing. It will prompt you to save the edits before 

closing. Agree to save the edits by clicking on Yes. 

 

 

Final output: A polygon shapefile of the Land Cover Map for the AOI with features aggregated into 6 or 7 classes. 

B.2 Cropping of the aggregated land cover map to the REDD+ site 
• Data required:  

o Shapefile of the aggregated land cover map (product of B.1) 

o Shapefile of area of interest (i.e. REDD+ site only) 

• Software: ArcMap 

• Purpose: To focus the analysis on a specific area (3 municipalities vs. entire Province).  
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If initially, the AOI has been focused only on specific municipalities and not the entire province, this 

section may be skipped already. 

 

1. Continuing from the previous section (still in ArcMap), keep only two shapefiles – aggregated land cover map 

from B.1 and the AOI (i.e. REDD+ site boundary data). 

2. Find the Search tool in the toolbars and click it. 

 

Type in ‘clip’ and click on the Clip (Analysis) (tool) option. 

 

3. The Clip window will appear. 

 

The Input Features should be the file to be clipped (i.e. land cover map). 

 

The Clip Features should be the file that will be used to clip the Input Features file (i.e. AOI like REDD+ area 

only). 

 

After selecting the correct files, click OK.  

 

The end product will be a land cover that covers only the AOI (REDD+ area). 

  



 
    

 
55 

 
 

4. Wait for the clipping to execute. A new file will appear in the Table of Contents. This is now the clipped version 

of the land cover map.  

 

Final output: A polygon shapefile of the Land Cover Map covering a specific area (smaller area i.e. REDD+). 

B.3 Generate systematic stratified sampling points 
• Data required: Shapefile of the clipped land cover map (product of B.2) 

• Pre-formatted spreadsheet: Random Number Generator 

• Software: ArcMap and MS Excel  

• Purpose: To generate a sampling scheme for the different classes found in the AOI and to have separate 

samples for training and accuracy assessment for each class. 

 

1. Continuing from the previous step of B.2, remove all other files except for the final output. 

 

Find the Search tool in the toolbars and click it. Type ‘fishnet’ and click on the Create Fishnet (Data 

Management) (tool) option. 
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This tool will help you to generate a systematically distributed set of points. 

 

2. The Create Fishnet window will appear. Supply the necessary information as seen in the next image. 

 

After selecting a file for the Template Extent, the coordinates of the extent of the file’s image will appear on the 

Left, Bottom, Top and Right boxes. 

 

Revise the extent of your preference and supply the cell size (width and height).  

 

Do not forget to check the box for the Create Label Points (optional) before clicking OK.  
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3. A polyline layer and a point layer will appear in the Table of Contents and will look like the following image. 

 

The important file here is the point feature (label). These will be the sample points to be used for each class 

and then separated as training and accuracy assessment samples.  

 

The polyline (grid) can be turned off or removed from ArcMap. 

 

 

4. The point feature (grid_label), by default, does not have a coordinate system yet. 

 

Right click on the file from the Table of Contents and click on Properties. 
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The Layer Properties window will appear and when the Source tab is selected, the Coordinate System will be 

<undefined>. 

 

5. To assign a coordinate system for the point feature, look for the ArcCatalog  icon in ArcMap and click it. 

 

The ArcCatalog should appear within the ArcMap window, usually on the right side. Navigate to where the 

point feature is located and right-click on the file and click on Properties. 
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The Shapefile Properties window will appear and by clicking on the XY Coordinate System tab, the coordinate 

system can be selected. Scan through the folders of the Geographic or Projected Coordinate Systems and find the 

appropriate system for the dataset that you are working with. In this case, the area is within the WGS1984 

UTM Zone 52N. Note that it may be different for your AOI. When you have selected the correct coordinate 

system for your AOI, click OK.  

 

6. Check again the Properties of the shapefile by right clicking on the file from the Table of Contents and clicking 

on Properties. 

 

The Layer Properties window will appear and when the Source tab is selected, the Coordinate System will now have 

a Projection and Datum, which should match the items selected in the previous step. 
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7. To segregate the points by class, clip the points using the land cover map.  

 

Right click on the land cover map and click on Open Attribute Table. Select a class (i.e. Wooded Grassland) 

by clicking on the box before the FID column.  

 

8. Find the Search tool in the toolbars and click it. Type ‘clip’ and click on the Clip (Analysis) (tool) option. 
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9. The Clip window will appear. 

 

Select the grid points as Input Features and the land cover map where a specific class has been pre-selected (i.e. 

Wooded Grassland, as done in step 6) as the Clip Features. 

 

Give a name to the clipped grid points corresponding to the class that was used to clip it (i.e. 

samplePts_Grassland). Click OK to run the tool. 

 

10. A new point file will appear in the Table of Contents. These are now all the possible points that can be used as 

Grassland training and accuracy assessment samples. 

 

Repeat steps 7-9 for each class available (Forest, Annual Crop, Perennial Crop, Wetland, Built up and 

Open/Barren).  
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11. To separate the samples for training and for accuracy assessment, open the Random Number Generator MS 

Excel file. 

 

This Random Number Generator was also used in the first manual (Estomata, 2014). It generates random 

numbers from 1 to the total number of available samples, with no repetitions.  

 

Follow the instructions found on the sheet so that you can generate your random samples. The first 20 random 

numbers were selected as training samples and the rest will be used as accuracy assessment samples. You may 

change the selection as preferred (i.e. equal number of training and accuracy assessment samples). 

 

How to apply the random selection to the GIS data (section A.9.4 of the first manual (Estomata, 2014)) is 

described in the next steps. 

 

------- Steps 12-20 are from Estomata (2014) ----- 

 

12. Right-click on a Shapefile (i.e. Coconut Palm class) and click Open Attribute Table.  
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13. Select the features corresponding to the numbers generated in Step 11. 

 

14. After selecting the first 20 randomly generated numbers from the Table, right click on the Shapefile from the 

Table of Contents and click Data > Export Data… 

 

15. The Export Data window will appear. Make sure that only the features selected in the previous step are being 

exported. Click on the folder tool  and navigate to the desired location. Supply a filename and click OK. 

This will be the shapefile for the training samples of the Coconut Palm class. 
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16. A prompt will appear if you would like to add the exported data to the map as a layer, select Yes to make the 

new file appears in your Table of Contents. 

 

17. Open the Attribute Table of the original Shapefile again (i.e. Coconut Palms) (see Step 12). 

 

18. In the Table window, click on the Switch Selection tool. This will invert the previous selection and will now 

correspond to the other half of the polygons, which are the accuracy assessment samples. 

 

19. Repeat Steps 14–16 to export the selected features in a separate Shapefile. This will be the shapefile for the 

accuracy assessment samples of the Coconut Palm class. 

 

20. Repeat Steps 11-19 for the other classes available. 

Final output: Two point shapefiles (training and accuracy assessment) for each class (Forestland, Cropland, 

Grassland, Coconut Palm, Wetland, Settlement and Other land).  
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B.4 Buffering of sample points 
• Data required: Shapefiles of the training and accuracy assessment samples of each class (product of B.2) 

• Software: ArcMap and Google Earth Pro 

• Purpose: To generate polygons to be analyzed later. Zonal statistics cannot be applied for point locations only. 

 

1. Continuing from the previous section, keep only one set of training/accuracy assessment sample points of one 

class in the Table of Contents. 

Note that it is better to work with one class at a time to avoid confusion during processing. 

Find the Search tool in the toolbars and click it. Type ‘buffer’ in the search box and click on the Buffer 

(Analysis) (tool) option. 

 

2. Select the file of the sample points as Input Features and supply the location and filename of the buffer file. 

 

The linear measurement of 25 meters was selected to match the visual assessments done for the field data of 

the FRA. You may adjust this measurement based on your preference. 

Select OK to run the buffer tool.  
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3. These buffered points will be cross-checked in Google Earth, therefore, the shapefiles will have to be converted 

to KML files. 

 

To do that, go to the Search tool and type ‘KML’ and click on the Layer to KML (Conversion) (tool). 

 

4. Select the buffered sample points as the layer to be converted to KML. Supply the file location and filename. 

 

Do not forget to check the box for Clamped features to ground (optional).  

 

Click OK to run the tool. The output KML/KMZ file can now be opened and inspected in Google Earth.  

 

5. Repeat Steps 1-4 for the other classes available. 

 

6. Do not close ArcMap and proceed to the next section. 

Final output: two polygon shapefiles (training and accuracy assessment) for each class (Forestland, Cropland, 

Grassland, Coconut Palm, Wetland, Settlement and Other land) and KML versions of these shapefiles.  
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B.5 Forest Resources Assessment into GIS 
• Data required: FRA data (latitude and longitude) in spreadsheet 

• Software: Spreadsheet software (MS Excel, etc.) and ArcMap 

• Purpose: To convert the tabular information from the field into GIS/spatial data 

 

1. Prepare the spreadsheet so that it can easily be interpreted by ArcMap. The simpler the spreadsheet, the better. 

 

The first row should be the column names and the rest are the data from the field. The following table is a 

simple example of what a spreadsheet may contain that can be imported into ArcMap. 

 

Save the spreadsheet into an Excel 97-2003 Workbook (.xls) format. ArcMap cannot import the file if it is in 

“.xlsx” format. 

ID actual_northing actual_easting sampling_date 

1442993952857123 803539 203365 2015-09-09 

1442998136019079 804566 201380 2015-09-11 

1443000982794135 802491 207347 2015-09-08 

 

2. Open ArcMap and click on the Add Data icon . Navigate to the folder containing the spreadsheet that you 

want to import. 

 

Double click on the icon of the spreadsheet and then select the sheet name that contains the data from the 

field and click Add.  
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3. The file will appear in the Table of Contents. Right click on the file and select Display XY data.  

 

4. The Display XY Data window will appear. Select the fields that correspond to the X and Y Fields. If elevation 

data are available, these can be selected as the Z Field. 

 

Click on the Edit… button to change the Coordinate System to that which was used during the fieldwork (i.e. 

WGS84 UTM Zone 52N). The example presented may differ from what your field personnel used so it is best 

to check with them first. Click on OK. 
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5. The displayed data will appear in the Table of Contents as point shapefile. This is a temporary file and needs to be 

saved by right clicking on the file and selecting Data > Export Data. 

 

The Export Data window will appear. Supply a location and filename and click OK to save the file. 

 

6. A prompt will appear if you would like to add the exported data to the map as a layer, select Yes to make the 

new file appear in your Table of Contents. 

 

7. Repeat the buffering steps discussed in B.4 (Step1-2). The input file should be the point shapefiles generated 

in the previous steps. 

 

You may vary the buffer distance depending on the homogeneity of the samples based on Google Earth 

images (in the case of this work, a 30-35 meter buffer zone was used instead of 25m).  

 

Note: If some samples overlap due to the buffering step, merge these samples. The buffering steps 

would be similar to Steps 8-11 of B.1. 

 

8. Repeat Step 11 of B.3 to generate random numbers and to generate the training and accuracy assessment 

samples for the Forest class, repeat Steps 12-19. 

 

9. Convert the samples to KML by using Steps 3-4 of B.4. 

 

10. Do not close ArcMap. 

Final output: two polygon shapefiles (training and accuracy assessment) for the Forest class and KML versions of 

these shapefiles.  

 

B.6 Cross-checking of samples in Google Earth Pro 
• Data required:  

o Shapefiles and KML files of all training/accuracy assessment samples 

o Georeferenced PALSAR-1/2 files (product of Chapter A) 

• Software: ArcMap and Google Earth 

• Purpose: To double check if the samples based on the FRA and the NAMRIA Land Cover map are consistent 

with current and historical images from Google Earth. 

 

1. Open the shapefiles of one set of training and accuracy assessment samples of a class (i.e. cropland) and 

the corresponding georeferenced PALSAR-1/2 file(s) in ArcMap  

 

If the shapefiles are from AOI#1 then the georeferenced PALSAR-1/2 image should also be from AOI#1. Do 

not use the PALSAR image from another area or else the shapefile will fall outside the radar image. 

 

2. Open the corresponding KML files (i.e. must also be cropland) in Google Earth and scan through the images 

available (through different years) for each feature of the KML file. 
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The Time Slider tool will allow you to look at images taken in different years. Through this, you can determine 

if a sample is consistently composed of a single class throughout time. 

 

3. If a sample (i.e. cropland) does not match the Google Earth images (i.e. coconut palm or initially forest then 

cropland), then this sample is removed or moved to an area that has the land cover that corresponds to the 

class name. 

 

There are two ways to do this: 

o Adjust the samples in ArcMap or 

o Adjust the samples in Google Earth Pro and import it into ArcMap 

The latter is a longer process, therefore, the former option will be discussed here instead. 

4. In Google Earth Pro, click the Ruler icon  to show the Ruler tool.  

 

Click on the center of the sample (red circle) and click on the location of the land cover that corresponds to 

the class name (i.e. cropland). 

 

Take note of the measurement (i.e. 190 meters).  

 

 

5. On ArcMap, select the Measure icon  to show the Measure tool.  

 

Click on the center of the sample (i.e. black circle, which is exactly the same as the red circle in Google 

Earth) and replicate the distance and angle of the line shown in Google Earth. 
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This is now an indicative area of where the “cropland” is on your radar image and where your sample (black 

sample) should be placed/moved. 

 

6. Move the sample to the correct location. To do this, go to Editor > Start Editing to activate the editing of 

the shapefile. 

 

Repeat steps 4-5 for every sample that is incorrectly represented in Google Earth. This is to make sure that each 

sample of each class is correct based on actual high resolution satellite images / aerial photos available in 

Google Earth.  
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7. Repeat Steps 1-6 for all other classes available.  

Final outputs: Corrected and double-checked polygon shapefiles for all classes available. Each class has separate 

shapefiles for training samples and accuracy assessment samples. 

Note: The samples taken by the author were consistent through time (2000 to 2015/6/7) based on the images from 

Google Earth using the Time Slider tool. This was done so that the samples may be used for all radar images 

available (2007, 2010 and 2015). 

  



C. Forest cover sample analysis
and classification, accuracy 
assessment and unbiased 
area estimation
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This chapter requires the shapefiles of the training and accuracy assessment samples (products of Chapter B) and 

the georeferenced radar images (products of Chapter A). 

The final product of GP3 will be forest cover maps with accuracy assessments and unbiased area estimations. Chart 

4, Annex 5 illustrates all the steps applied in this chapter. 

Note: If you already have thresholds that can be used to classify the radar images, proceed to section C.6.  

C.1 ROI separability check 
• Data required:  

o Georeferenced radar image (product of Chapter 0) 

o Shapefiles of training and accuracy assessment samples (product of Chapter 0) 

• Software: ENVI 5.x (classic view) 

• Purpose: To determine how separable/distinguishable classes are from each other. 

 

1. Open ENVI 5.x (classic view). 

2. Click on File > Open… and navigate to the folder containing the georeferenced radar image file of your selected 

AOI. Select the file and click Open. 

3. Open the training samples shapefile (all classes) by clicking on Vector > Open Vector File. 

 

4. The Select Vector Filenames window will appear. If the vectors are in an ENVI Vector File (*.evf) format, do the 

following steps. If it is in a different format (i.e. Shapefile), proceed to Step 5. 

 

a. Change the file format to ENVI Vector File (*.evf) and navigate to the folder containing the files. Select 

the files needed and click Open. 
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b. The Available Vectors List window will appear. Proceed to Step 6. 

 

5. If the vectors are in a Shapefile (*.shp) format, do the following steps: 

a. In the Select Vector Filenames, change the file format to Shapefile (*.shp) and navigate to the folder 

containing the files. Select the needed files and click Open. 

 

b. The Import Vector Files Parameters window will appear. To save the ENVI Vector File (EVF) version of the 

Shapefile, click on the radio button File and click on Choose to select the desired save location. Supply a 

filename for the Shapefile. 

 

Repeat for each Selected Input File available and then click on OK. 

 

Click on the radio button Memory for the files you do not wish to save. Or click on the Output to 

Memory for All, if you do not wish to save any file. 

 

Make sure that the projection setting is correct (in this example: UTM, Datum: WGS 84, Units: Meters, 

Zone: 51/52 N). 

 

When done, click OK. 
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c. The Available Vectors List window will appear.  

  



 
    

 
77 

 
 

6. On the Available Vectors List window, click on Select All Layers to select all the available classes in the Vector 

List. 

 

7. Navigate to File > Export Layers to ROI… 

 

The Select Data File to Associate with new ROIs window will appear. Click on the georeferenced file opened in Step 

2 and click on OK.  

 

The Export EVF Layers to ROI window will appear. Select the radio button for the first option (Convert all 

records of an EVF layer to one ROI…) and click on OK. 
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8. On ENVI’s menu bar, navigate to Basic Tools > Region of Interest > Compute ROI Separability. 

 

9. The Select Input File for ROI Separability window will appear. Select the georeferenced radar image and click 

Spectral Subset. 

 

Select only the first 7 bands and click on OK to go back to the Select Input File for ROI Separability window. 
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10. Note that the Spectral Subset will show how many bands you have selected compared to the total bands available 

(i.e. 7 out of 10). Click again the OK button to proceed to the next step. 

 

11. The ROI Separability Calculation window will appear. Select the desired classes for the Select Input Regions or click 

on Select All Items if all classes are desired. Click on OK to run the analysis. 

 

 

12. If an error occurs, such as those shown in the following image and the resulting ROI Separability report 

generates an output of only 0.0 for all classes, repeat Step 9 and try to remove one or two more bands from the 

File Spectral Subset list. Then repeat Steps 10-11.  
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Note that in this work, band 5 and band 6 gave errors and were therefore not included in the ROI Separability 

analysis. 

 

13. An ROI Separability Report will appear in a new window. 

 

The separability values can range from 0.00 (not separable) to 2.00 (very separable). These values indicate how 

distinguishable two classes are in a specific image.  
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14. To save the report, click on File > Save Text to ASCII… 

 

The Output Report Filename window will appear. Click on Choose to navigate to the folder where you want to 

save the report. Supply a filename and click OK. 

 

15. Close all windows of the ENVI software. 

Final output: ROI separability values between classes.  

C.2 Zonal statistics analysis 
• Data required:  

o Georeferenced radar image (product of Chapter A) 

o Shapefiles of training and accuracy assessment samples (product of Chapter B) 

• Python script: Scripts found in “ZonalStat” folder 

• Software: Xubuntu_RSGISLib via Oracle VM VirtualBox 

• Purpose: To automatically calculate the statistics of the radar data in identified zones/samples. This can also be 

done manually using ArcGIS. 

 

1. Open the RSGISLib.ova in the VirtualBox software. 

 

Drag and drop the georeferenced radar images and the training samples shapefiles from your host 

operating system in Xubuntu_RSGISLib. 

 

Put all the files into one folder. Segregate them into folders so that all the radar datasets are in a folder named 

data and all the shapefiles are in the folder shp. 
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In the same folder, make a new folder named stat. The main folder should contain three folders and the zonal 

stat Python script. 

 

2. Open the Python script and make sure that the input files in the script correspond to the files in the data and 

shp folders. 
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3. Open the Terminal Emulator and navigate to the folder where the files are located. 

 

Run the zonal statistics script by typing ‘python script_name.py’ in the Terminal.  

 

4. Navigate to the stat folder to see the text files generated by the Python script. 

 

Open the text files to check if statistics were generated. If the statistics are only “0” (zero) values then a 

possible reason may be that the input files had incorrect reference systems, as experienced by the author. 

 

Make sure that the reference systems used by your images and shapefiles are correct (correct zoning 

values – i.e. Zone 51 or Zone 52, etc.). 

 

5. The FID in the text file corresponds to the FID of each feature of the shapefiles. If a shapefile has 20 

features/samples then the text file will contain 20 rows of statistical data. 

 

This is a way to check if the statistics you are generating actually correspond to the correct shapefiles. 

 

6. The statistics calculated are the average and standard deviations of all bands for all the features of the 

shapefiles. 

• b1Avg is the average of all the pixels of band 1 (HH) for a feature (i.e. with FID 0) of a shapefile. 

• b1Std is the standard deviation of all the pixels of band 1 (HH) for the features of a shapefile. 

• “b2” is band 2 and so on. 

 

7. Moves the files from Xubuntu_RSGISLib to Windows 7 and close Xubuntu_RSGISLib. 

Final output: 1 text file for each class which contains the statistical characteristics of each band for all features 

present in each class. If there are 6 classes then there should be 6 text files. 
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C.3 Integration of all zonal statistics into CSV files 
• Data required: Text files containing all zonal statistics information gathered for one satellite (PALSAR-1 or 

PALSAR-2) 

• Pre-formatted spreadsheet: CSV file for boxplots and thresholds 

• Software: Spreadsheet software (MS Excel/OpenOffice Calc) 

• Purpose: The input for the next section requires a CSV file with specific formatting and column names. 

 

1. Open the OpenOffice Calc spreadsheet software or any spreadsheet software that you prefer to use. 

 

Select the text files containing the zonal statistics information generated in 0 and drag then drop it to the 

OpenOffice Calc. 

 

The Text Import window will appear. Make sure that the selected Separator option is separated by Comma. Click 

OK. 

 

Repeat this for every file dragged and dropped into the spreadsheet software. 

 

2. From the zonal statistics table, copy and paste the 14 columns after the first column (FID) into the supplied 

formatted spreadsheet. 

 

The following table shows the information/data that the spreadsheet should contain. A full table is also shown 

in the Annex 4. 

 

The LCCode is the land cover code while Prov is the Province where the sample is located. The rest are the 

names of the bands and the ratios (HH, HV, HHoverHV etc.). 
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The zonal statistics determined by the code are only the mean and standard deviation of the band in the sample 

area. Please refer to the technical report (Estomata, 2017) for a detailed explanation of zonal statistics. 

 

Make sure that the spreadsheet is properly filled in as this will be an input to generate boxplots and the 

thresholds for decision tree classification. 

 

Do not forget to change the year to the corresponding year/s in the “Year” column as this will be 

reflected on the boxplots. 

 

The LCCode that has to be used are as follows: 

• Wetland as “Wet” 

• Settlement as “Sett” 

• Forest as “Forest” and 

• Aggregate all non-forest classes (Crop, Grassland and Coconut Palm) into one class named “NF” 

Year LCCode Prov HH HHstd HV HVstd 

2010 Wet Albay (value) (value) (value) (value) 

2010 Sett Albay (value) (value) (value) (value) 

2007 Forest Eastern Samar (value) (value) (value) (value) 

2007 NF Davao Oriental (value) (value) (value) (value) 

 

3. Close the spreadsheet application once you are satisfied with the preparation of your CSV files. 

 

Final output: 1 CSV file containing the statistical characteristics of all features present in each class. The classes that 

are included in the CSV file depend on the results of the ROI separability analysis (result of C.1) and is further 

elaborated in the technical report (Estomata, 2017). 

The rule of thumb followed in the report to fill in the CSV file are: 

• All Forest samples were included. 

• All classes when compared to Forest that had ROI separability values of at least 1.99 were also included in the 

list. 

• All classes when compared to Forest that had ROI separability values less than 1.99 were discarded. 

Note: One CSV file will cater to all statistical information gathered from PALSAR-1 and another CSV file will 

consolidate statistical information from PALSAR-2. They will not be lumped together into one file and 

analysis. 

C.4 Boxplots generation 
• Data required: Spreadsheet with all relevant zonal statistics information in CSV format 

• R Script: Scripts to generate boxplots from the CSV file 

• Software: RStudio 

• Purpose: To generate boxplots that will help to determine predictor variables identified in the next section. 

 

1. Move the CSV file generated in the previous section to the folder containing the R scripts for generating 

boxplots and thresholds. 

 

2. Open the RStudio software. Open the R script to generate boxplots. 

 

3. Check if the path name of the working folder where the script is located is correct. 
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If you choose to copy the address of the CSV file you have created, be sure to change the backslash (\) to slash 

(/) after pasting. This is a convention of the R language. 

 

If the working folder is inconsistent with the actual location of the script and files, the R script will not run 

correctly and will generate empty boxplot images. 

 

 

4. Check if the CSV file read corresponds to the file that you have prepared in C.3 (i.e. “Palsar1_Samples.csv”). 

 

Check also that the LCCode in the script corresponds to the LCCode you have used in the spreadsheet. 

 

If they do not match, change the LCCode used in the spreadsheet to match those that are used in the script. 

 

Do not change the LCCode used in the script unless you are familiar with the R language. 

 

5. Select all of the text of the script (shortcut: Ctrl+A) and click on the RUN button to run the script. This will 

generate 7 boxplot images in the working folder you have set in Step 3. 
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6. Do not close RStudio and proceed to the next section. 

Final output (per sensor): 

• 7 boxplots – 1 for each band/ratio showing the separability of the different classes. 
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C.5 Threshold generation 
• Data required: Spreadsheet with all relevant zonal statistics information in CSV format and boxplots generated 

in C.4 

• R Script: Scripts to generate the thresholds for the decision tree classification 

• Software: RStudio 

• Purpose: To automatically generate thresholds to separate the different classes. 

 

1. Open the R script that generates the thresholds. 

 

Check if the path name of the working folder where the script is located is correct. Again, if you choose to copy the 

address of the CSV file you have created, be sure to change the backslash (\) to slash (/) after pasting. 

 

If the working folder is inconsistent with the actual location of the script and files, the R script will not run 

correctly and will generate empty decision tree images. 

 

2. Scroll down through the code and look for the part which looks like the following image.  

 

Based on the boxplots generated in the previous section, identify the bands (predictor variables) where the classes 

described below are most separable. Change the predictor variables in the script according to your boxplots. 

The predictor variables that you can choose from are the band names: HH, HV, HHHV, HVHH, HHHVave, 

NL, and NDI. The variables are separated by the “+” sign. The classes are separated into three hierarchical levels: 

LC1, LC2 and LC3. 

• LC1 (the first line in the previous image) corresponds to the separability of all land classes versus 

wetland/flooded crop.  

• LC2 (the second line in the previous image) corresponds to the separability of all vegetation against 

settlement/bare soil.  

• LC3 (the last line in the previous image) corresponds to the separability of the forest and non-forest classes. 

To illustrate how this is done, the following boxplots show that bands HH, HV, HHHVave, and NL can 

differentiate Wetlands/Flooded Crop from Land. The blue dotted line shows probable point of separation which 

will be automatically calculated and identified by the R script. 
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3. When you are satisfied with the selected predictor variables, select all of the text of the script again (CTRL+A) 

and hit RUN (same as Step 5 of C.4). 

 

This will generate images of the decision trees that show the thresholds that will be used for the decision tree 

classification. 

 

4. If an error occurs (Error: could not find function "tree"), type install.packages('tree') in the Console of 

Rstudio. 

 

If you have internet, this should download and install the tree package.  

 

5. Repeat Step 3 and this time it should run without error. 

 

The outputs will be found in the directory/path that you have entered in the script (Step 1).  

 

6. To interpret the decision trees from R, please refer to Annex 3. 

 

7. If some parts of the decision tree become too complicated (branchy), you can remove some predictor variables 

(part of Step 2) that do not provide significant differentiation (based on the boxplots) of the classes that you 

want to be separated.   



 
    

 
91 

 
 

The following boxplot illustrates that the HV/HH band is not a good predictor variable to separate 

Wetland/Flooded Crop from Land classes (which could be Forest, Settlement or Non-Forest). 

 

Therefore, this band (HV/HH) should not be part of the predictor variables found in Step 2. 

 

 

8. Once you are satisfied with the decision trees and thresholds that the script has generated, close the RStudio 

application. 

Final outputs (per sensor): Thresholds within the decision trees. 

Note: The steps for C.1 to C.6 are repeated if images from a different satellite is being analyzed (PALSAR-1 vs. 

PALSAR-2). 

Therefore, the decision tree for PALSAR-1 will only be applied to images taken by PALSAR-1 (2007-2010) and a 

different decision tree will be used for images acquired by PALSAR-2 (2015 onwards). 

C.6 Decision tree classification 
• Data required: Georeferenced radar image (product of Chapter A) and the decision trees and thresholds from 

C.5 

• Software: ENVI 5.x (classic view) 

• Purpose: To generate classification images based on the thresholds identified in the previous section. 

 

1. Open ENVI 5.x (classic view) and open the georeferenced radar image produced from Chapter A. 

 

Since the classification algorithm to be used in this manual is a decision tree classifier, no training 

samples/ROIs are required to apply the classification.  
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2. On the Menu Bar, click on Classification > Decision Tree > Build New Decision Tree. 

 

3. The ENVI Decision Tree window will appear.  

 

In this window, replicate the decision tree generated by C.5 (or use the info that you may already have). 

 

The following decision tree is generated by C.5 for ALOS-2 PALSAR-2 and is also the example elaborated in 

Annex 3. 
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When the decision tree from R is translated into ENVI’s Decision Tree, it would look like the following image: 

 

4. To learn how to use the decision tree window, please check the Help page of the software under the topic: 

Decision Tree. The topic on Decision Tree Variables and Expressions will be most useful for this section. 

 

 

5. To edit the expressions for the Decision Tree, click on the box named “Node 1”. The Edit Decision Properties 

window will appear. 

  



 
    

 
94 

 
 

In the Name box, type a name of the classes you intend to separate (i.e. Wet/Land – to separate Wetland 

areas from Land areas).  

 

In the Expression box, enter the expression that will separate Wetland from Land areas (i.e. the first 

decision on the decision tree found in Step 3 which is “HH less than -16.2925”). 

 

Once you are satisfied with your inputs, select OK. 

 

 

The relational operators useful for the decision trees are as follows: 

• LT – less than (<) 

• LE – less than or equal to (≤) 

• EQ – equal to (=) 

• GE – greater than or equal to (≥) 

• GT – greater than (>) 

The variables would refer to the bands available in the data (band 1, band 2, etc.). Variables may be named “bx” 

where x is a number (i.e. b1, b2, b3, etc.). This convention is similar to how variables are named when using 

ENVI’s band math tool. 

If a variable is part of a multiband file (more than 1 band such as in this manual where the file being used has 10 

bands), the variable should have a subscript in square brackets (i.e. {variable[n]}). 

The subscript (n) is the band number that begins from 1 to the total number of bands available. 

In the following image, the variable for the Davao Oriental file is {DO}. 

To refer to the different bands, just replace the number inside the closed brackets {}. 
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So if the variable is {DO[5]} then it is referring to band 5 of the Davao Oriental file. 

 

6. Click on the box for the resulting class (i.e. Class 1). Change the Name to the appropriate class name (i.e. 

Wet/FloodedCrop). 

 

Avoid using the value zero (0) as Class Value. Make sure that all matching classes would have the same 

value (i.e. 1 for Wet/FloodedCrop, 2 for Settlement, 3 for Forest, 4 for Non-Forest).  

 

Change the default color of the class to an appropriate color to the class being classified (i.e. blue). Click on 

OK when you are satisfied with the parameters. 

 

Note that in ENVI’s Decision Tree tool, the results on the right side are those that agree with the inputted 

expression. This is opposite of the convention of the Decision Trees from R. 

Take note of this difference and be careful when putting the expressions into ENVI. 

7. To add more Decisions (nodes), right-click on a class and click on Add Children. 

 

The previous properties of that class (i.e. “Land”, Class 0, Black) will change and become empty. 
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Click on the empty box to edit the properties. 

 

8. Repeat Step 5 to edit the Decision Properties and Step 6 to change the Properties of the classes.  

 

9. If more decisions/expressions have to be included in the Decision Tree, repeat Steps 7 to 8. 

 

10. Click on Options in the menu bar and hit Execute. 
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11. If you have already paired all your variables to the correct bands of your radar image, the process will complete 

with no error. 

 

If you have not yet paired your variables, an error will occur stating that you need to pair a variable with a file. 

 

12. To pair the variables with the bands/files, click Options on the menu bar and click on Show Variable/File 

Pairings.  

 

The Variable/File Pairings window will appear. 

 

If you used individual bands for each variable (i.e. {b1}, {b2}, etc.), the Variable/File Pairings window will look 

like the following image. 

 

If you used one variable for a multi-band file (i.e. {DO[n]}, the Variable/File Pairings window will look like the 

following image. 
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13. Click on one of the Variables (i.e. {b1}) and the Select Band to Associate with Variable “{b1}” window will appear.  

 

Select the band which corresponds to {b1} then click OK. 

 

Repeat this step until all variables have been paired. 
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14. When all variables have been paired, it should appear as shown in the next image. 

 

 

15. Repeat Step 10, click on Options on the menu bar and hit Execute. This time, it should complete without error 

because all variables have been paired.  

 

The Decision Tree Execution Parameters window will appear. If you wish to save the result, hit the radio button File 

and supply the filename and location. If you do not wish to save the result, just click on the radio button for 

Memory. Click OK to run the decision tree classification. 

 

16. Wait for the execution to finish. A new file will appear in the Available Bands List. This is now the classification 

image to be used for C.7. Do not close ENVI and proceed to the next section. 

C.7 Post-classification 
• Data required:  

o Classification image from C.6 

o Georeferenced radar image (product of Chapter A) 

• Software: ENVI 5.x (classic view) 

• Purpose: To remove isolated pixels from the classification image and simplify it into a Forest and Non-Forest 

map. 

 

1. Continuing from the previous section, make sure that the classification image (product of C.6) as well as the 

georeferenced radar image (product of Chapter A) are the only files present in the Available Bands List window.  
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This is to avoid confusion which files to use in this section. 

 

2. On the menu bar, find the Basic Tools > Masking > Apply Mask.  

 

The Apply Mask Input window will appear. The Select Input File should be the classification image from C.6. The 

mask band is the band 8 of the georeferenced radar image (product of Chapter A). 

 

To select Band 8 as the mask, click on the Select Mask Band to open the Select Mask Input Band window. 

Select Band 8 and click OK twice. 

 

3. The Apply Mask Parameters window will appear. Keep the Mask Value to zero (“0”). 

  



 
    

 
101 

 
 

 

If you wish to save the result, hit the radio button File and supply the filename and location. If you do not wish 

to save the result, just click on the radio button for Memory. Click OK to run the Apply Mask. 

 

4. Navigate to the Classification > Post Classification > Majority/Minority Analysis. 

 

5. The Classification Input File window will appear. Select the masked classification image generated from Step 3 and 

click OK. 

 

6. The Majority/Minority Parameters window will appear. Select the classes that need to undergo the analysis (usually, 

all classes).  

 

Choose the desired settings on the Analysis Method, Kernel Size and Center Pixel Weight. 

 

Once satisfied with the parameters, click on the radio button File and click on Choose to select the desired 

save location. Enter a filename and then click on OK. 
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The Majority Analysis process window will appear. A new file will appear in the Available Bands List after the 

process finishes. This new file will be used for the next step – Combine Classes. 

 

7. Navigate again to the menu bar and click on Classification > Post Classification > Combine Classes. 

 

8. The Combine Classes Input File window will appear. Select the file generated in Step 0 and click OK. 

 

The goal is to end up with only two classes – Forest and Non-Forest, therefore, all non-forest classes under 

the Select Input Class must be matched with Non-Forest class under the Select Output Class.  

 

Do not forget to click on the Add Combination button.  

 

Once all Select Input Classes have been paired with their respective Output Classes, they will all appear under the 

Combined Classes. Click OK.  
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9. The Combine Classes Output window will appear. Click on the up and down arrow to change the selection for the 

Remove Empty Classes to Yes.  

 

If you wish to save the result, hit the radio button File and enter the filename and location. If you do not wish 

to save the result, just click on the radio button for Memory. Click on OK to run the Combine Classes tool. 

 

10. A new file will appear in the Available Bands List. This file will be used for the next step – Accuracy Assessment. Do 

not close ENVI. 
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C.8 Accuracy assessment 
• Data required:  

o Post-classified image from C.7 

o Accuracy assessment shapefiles from Chapter B 

• Software: ENVI 5.x (classic view) 

• Purpose: To calculate the accuracy of the maps generated using ground truth samples/regions of interest 

(ROIs). 

 

1. Continuing from the previous section, keep only the post-classification file from C.7 in the Available Bands List. 

 

2. Open the Shapefiles/ROIs which is needed for verification by clicking on the toolbar Vector > Open Vector 

File.  

 

3. Navigate to the folder containing the Shapefiles/ROIs/EVF, select the files needed and click Open. 

 

4. The Import Vector Files Parameters window will appear. If the vector files are in ENVI vector file (.evf) format, 

please see Step 4 in C.1. If the file is a shapefile (.shp) please see step 5 in C.1. 

 

5. Proceed to Steps 6-7 of C.1 to convert the vector files to ROIs. 

 

To change the ROI names, navigate to the window showing the post-classified image from C.7 and click on 

Overlay > Region of Interest… This will open the ROI Tool window. 

 

6. To change the ROI Name double click on the ROI names and type the name that you want to use. 
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7. If your ROIs have not been simplified to Forest and Non-Forest like the classes of the post-classified image of 

C.7, the classes have to be merged. 

 

You can also merge the Non-Forest classes (Coconut Palm, Cropland, Grassland, Settlement, and Wetland) 

using a GIS software. But the process can also be done using ENVI. 

 

In the ROI Tool window, click on Options > Merge Regions… 

 

8. The Merge ROIs window will appear. 

 

From the left box, select a Base ROI where all ROIs selected on the right box will merge. Since in this case, 

the goal is to combine all Non-Forest classes into one class, any Non-Forest ROI can be selected as the Base 

ROI and all Non-Forest ROIs on the right box have to be selected.  

 

To select multiple ROIs, hold the CTRL button on your keyboard while clicking your left mouse button on 

the ROI name. 

 

Make sure that the Delete Merge ROIs option is on YES and when satisfied with your selection, click on OK. 
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9. After the merge process ends, the ROI Tool window will re-appear and only two classes will be left: Forest and 

the Base ROI selected in the previous steps (i.e. Coconut Palm). 

 

Double click on the ROI name to change it to the more general ROI name (i.e. Non-Forest). 

 

10. On the toolbar, click on Classification > Post Classification > Confusion Matrix > Using ground Truth 

ROIs. 

 

11. The Classification Input File window will appear. Under the Select Input File, click on the post classified image 

(product of 0) and click on OK. 

 

12. The Match Classes Parameters window will appear. 

 

Click on the matching classes for both the Ground Truth ROI and Classification Image then click Add 

Combination. Once all necessary classes have been matched, click OK. 

  



 
    

 
107 

 
 

 

13. The Confusion Matrix Parameters window will appear. Make sure that both the Pixels and Percent check boxes 

are checked and that the radio file button “Yes” is chosen for the Report Accuracy Assessment. Click OK.  

 

14. The Class Confusion Matrix result window will appear. 

 

This is the accuracy assessment report for the classification image compared with the accuracy assessment 

samples. The following image is an example of the result of a confusion matrix. 
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Save the report by clicking on File > Save Text to ASCII… 

 

15. Do not close any window from ENVI and proceed to the steps of the next section. 

C.9 Unbiased Area Estimation 
• Data required:  

o Post-classified image from C.7 

o Confusion Matrix results from C.8 

• Pre-formatted spreadsheet: Unbiased Area Estimation (2 classes- Forest/Non-Forest) 

• Software: ENVI 5.x (classic view) and MS Excel 

• Purpose: To calculate bias-free estimates of Forest and Non-Forest classes. 

 

1. Continuing from the previous section, navigate to the Available Bands List and look for the post-classified 

image generated from C.7.  

 

Right click on the file or band and click on Quick Stats. The statistics results will appear in a new window. 
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Note the number of pixels classified as Forest (DN=2) and as Non-Forest (DN=1). These pixel numbers will 

be entered into the spreadsheet that calculates unbiased area estimates. 

 

2. If you are unsure of what classes the DN values correspond to, right click on the post-classified image from 

the Available Bands List window and select Load Band to New Display. Inside the image window, right click 

anywhere and click on Cursor Location/Value…  

 

The Cursor Location/Value window will appear but with no details. Hover your mouse over the different classes 

on the image window and take note of the DN value and the class that it corresponds to. 

 

In the following image, it says that DN=1 is Non-Forest and DN=2 is Forest, which confirms the information 

in Step 1.  
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3. Open the spreadsheet prepared for the unbiased area estimation of two classes (Forest and Non-

Forest).  

 

Note that the non-colored cells are locked/protected so that the formulas in the cells are not accidentally 

altered. 

 

4. Supply the necessary information based on the statistics of the classified image (highlighted by blue boxes) and 

the confusion matrix (highlighted by red boxes). 

• Blue boxes: the number of pixels classified as Forest and Non-Forest (statistics based on Step 1) 

• Red boxes: pixels based on the confusion matrix (output of C.8). 
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i. the number of pixels correctly classified as Forest and Non-Forest, respectively: 1,934 and 943 

ii. the number of Forest pixels incorrectly classified as Non-Forest: 43 

iii. the number of Non-Forest pixels incorrectly classified as Forest: 66 

iv. the Producer’s and User’s accuracy of the 2 classes: >93% 

v. the Overall Accuracy: 96.29%  

vi. the Kappa Coefficient: 0.9166 

Note: The steps from C.6 to C.9 are repeated for each mosaic scene of every AOI. Therefore, if Davao Oriental has 

2007-2010 mosaic scenes that you wish to classify, use the PALSAR-1 thresholds and for the 2015-2016 mosaic 

scenes use the PALSAR-2 thresholds. 

If you would like to apply unbiased area estimation calculations for more than 2 classes, unprotect the sheet by 

supplying the password “1234”. 

  



D. Deforestation sample collection 
and analysis for forest cover change 
classification
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The forest cover change classification applied in this work is a direct classification where the change analysis is 

directly applied to the radar images. It is therefore necessary to acquire samples of forest turning to non-forest based 

on the dates of the radar images.  

This chapter will illustrate the steps for the image to be analyzed for change, the process of selecting the 

Deforestation samples, obtain zonal statistics and finally identify the thresholds to separate Deforestation from 

Stable Forests. Chart 5, Annex 5 explains the process flow of this chapter. 

D.1 Generate the Difference Change Index (DCI) Image and combined radar effects 

mask of year1 and year2 
• Data required: Georeferenced radar images (product of Chapter A) of an AOI (i.e. 2010 and 2015) 

• Python script: Scripts found in “ChangeImages” folder 

• Software: Xubuntu_RSGISLib via Oracle VM VirtualBox 

• Purpose: 

o To create a “difference image” between 2 years of an AOI and use it as an input to the forest cover change 

mapping process. 

o To create a joint mask of the images used for generating the “difference image.” 

Note: If until this point, you have only been processing one mosaic scene (i.e. year 2010) and would like to analyze 

change between 2010 and 2015, the 2015 mosaic scene of your AOI would have to go through, at the least, the 

processes described in Chapter A. 

1. Open the RSGISLib.ova. 

 

Drag and drop the georeferenced radar images from your host operating system into Xubuntu_RSGISLib. 

 

Segregate the files into folders such that all the radar datasets are in a folder named data and all the output 

files will be in a folder named CD. 

 

The main folder should contain these two subfolders and the Python scripts that will calculate the DCI image 

and the combined radar mask effects. 

 

2. Open the Python scripts and make sure that the input files of the script correspond to the files inside the folder 

data. 

 

The output file will appear in the CD folder and will have the name DO_2010-2015_Diff.tif (as you will see in 

the script). You may change the name of the file as preferred but keep the format to TIFF to avoid errors 

when running the script. 

 

After your edits, save the script and close the gedit window.  
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3. Open the Terminal Emulator and navigate to the folder where the files are saved. Run the script that calculates 

the DCI image (DO_diff2010-2015.py) by typing ‘python DO_diff2010-2015.py’. 

 

4. Repeat steps 2-3 to generate the combined radar effects mask for 2010 and 2015. In this step, the Python script 

to check should be the one that calculates the combined mask (DO_mask_diff2010-2015.py).  

 

5. Copy both output files (DCI image and combined mask) of Step 3 and Step 4 to your host computer (Windows 

7) but do not close Xubuntu_RSGISLib yet. 

D.2 Identify the acquisition dates of the radar images 
• Data required: Acquisition date bands of the radar images used in D.1 

• Python script: Scripts found in “computeDate_ALOS” folder 

• Software: Xubuntu_RSGISLib via Oracle VM VirtualBox 

• Purpose: To identify the exact dates when the radar images were captured. This is important information that 

will be used to determine samples of change. 

 

1. Determine the folder location of the acquisition date images of the radar images. Since the radar images 

analyzed in D.1 were from 2010 and 2015 for Davao Oriental, the acquisition date images that should be 

checked in this section should come from the same area (Davao Oriental) and years (2010 and 2015). They 

should look like the files in the following image.  
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Note: If your VirtualBox and computer are powerful enough, you can also use the 10-band file generated for each 

year (product of Chapter A). The acquisition date band is band 10 of the stacked file/product. 

2. Open the Terminal Emulator and navigate to the location determined in Step 1.  

 

View the acquisition date file of the first image (year 1) by typing “tuiview  filename” in the terminal (i.e. 

“tuiview N08E126_10_date”). 

 

3. The Tuiview image viewer will open with the acquisition date file currently on view. 

 

Click on the Query Tool (+) and click around the image to identify the Digital Number (DN) values, which 

correspond to the acquisition dates of the radar images used on the radar mosaics.  

 

Note down all the Digital Numbers.  
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4. Close Tuiview to return to the Terminal Emulator. If you do not close Tuiview, the Terminal Emulator will not 

function correctly. 

 

5. Repeat Steps 2-3 for the acquisition date image of the second radar image (year 2) (i.e. “tuiview 

N08E126_15_date_F02DAR”).  

 

Again, take note of the Digital Numbers and close Tuiview. 

 

Close the Terminal Emulator when you have obtained all the Digital Numbers found in the acquisition date 

images. 

 

6. In the Terminal Emulator, navigate to the folder containing the script that computes the acquisition dates of the 

PALSAR-1/2 images. 

 

Run the Python script by typing “python computedateALOS.py” in the Terminal for acquisition dates of the 

PALSAR-1 images and “python computedateALOS2.py” for acquisition dates of the PALSAR-2 images.  

 

7. Upon execution of any of these two scripts, the Terminal Emulator will ask for a raw input from you: “How many 

DN values do you want to convert?”. 

 

Use the keyboard to input the number of DN values that you need to convert (i.e. 4). Hit the Enter key on the 

keyboard after supplying the number of DN values to be converted.  

 

8. The Terminal Emulator will again prompt you to input the DN values. Again, use the keyboard to input the DN 

values that you have identified in Steps 2-5.  
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9. It will automatically end when the total number of DN values identified in Step 7 have been converted. 

 

10. Before closing the VirtualBox, make sure that the Python code used to compute the acquistion dates 

corresponds to the correct satellite/sensor. 

• PALSAR-1 acquisition dates  computedateALOS.py 

• PALSAR-2 acquisition dates  computedateALOS2.py 

 

11. Close VirtualBox. 

D.3 Identify deforestation and stable forest samples 
• Information required: Acquisition dates of radar images (D.2) 

• Software: 

o Google Earth Pro 

o ArcMap 

• Purpose: To obtain deforestation samples that completely agree with the acquisition dates of the radar images. 

 

1. Open Google Earth Pro and try to find deforestation samples while keeping in mind the acquisition dates 

of the radar images. 

 

If the radar image in Year1 was acquired in June 2010 and the radar image in Year2 was acquired in October 

2015 then: 

Deforestation samples have to be as follows on Google Earth images: 

• Forest on or after June 2010  

• Deforested/Non-Forest on or before October 2015. 

Stable Forest samples have to be: 

• Forest on or after June 2010  

• Forest on or after October 2015. 
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2. After the polygons for the samples have been finalized, save the folder of polygons as a KML or KMZ file by 

right-clicking on the entire folder on the Places window pane and select Save Place As…  
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3. The Save file… window will appear. Navigate to the folder where you prefer to save the KML/KMZ file. Type 

a filename and click on Save. 

 

4. Import the KML/KMZ files into ArcMap by clicking on the Search tool and typing ‘KML’. Click on the 

KML to Layer (Conversion) (Tool).  

 

For the Input KML File, navigate to the folder where the KML/KMZ files (Step 3) were saved. Supply the 

output location and the filename and click OK. 

 

5. The output layer will appear in the Table of Contents of ArcMap. This file will have a Geographic Coordinate System 

of WGS 1984.  

 

Project the data to the projection that is appropriate for your data (in this example, UTM Zone 51/52) by going 

to the Search tool and type ‘Project’. Click on the Project Data Management (Tool). 

 

6. The Project tool window will appear. Supply the necessary information and click OK. 

 

The projected version of the imported KML file will appear in the Table of Contents. This file will be used for D.4 

and Chapter E. 
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7. If sufficient samples for training and accuracy assessment are available, repeat the random number generation 

and selection of training and accuracy assessment samples as done in Steps 11-19 of B.3. 

 

Otherwise, the training samples will also be the accuracy assessment samples (but this is not an encouraged 

practice). 

 

8. For the stable forest samples, the forest samples identified in Chapter B may be used as these were cross-

checked against Google Earth images if they were consistent through time (2000 to 2016/7). 

D.4 Identify thresholds for change analysis 
• Data required:  

o Georeferenced DCI image (product of D.1) 

o Shapefiles of training samples of Deforestation and Stable Forests (products of D.3 and Chapter B) 

• Software:  

o ENVI 5.x (classic view) 

o Xubuntu_RSGISLib via Oracle VM VirtualBox 

o Spreadsheet software (MS Excel/OpenOffice Calc) 

o RStudio. 

 

1. In order to identify thresholds for the change analysis, the steps in C.1 to C.5 have to be repeated. 

 

The data input should be the Difference Change Index (DCI) image (product of D.1) and the shapefiles 

should be the Deforestation and Stable Forests samples (product of D.3). 

The threshold determined in the study of Estomata (2017) is HV DCI > 2.0, i.e. if the HV DCI is greater than 2.0, 

it will be classified as Deforestation and if less than 2.0, it is classified as Stable Forests. 
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The decision tree looks like the following image: 

 

In the work of Reiche (2015) the threshold of HV DCI is 2.2 dB. You may choose to use these two thresholds to 

try the decision tree classification for forest cover change mapping, but it is highly recommended that you will 

generate your own thresholds from your own samples and datasets. 

Note: The steps elaborated in this chapter were specific to the years 2010 and 2015, which were acquired using 

PALSAR-1 and PALSAR-2. If a different set of years will be analyzed (i.e. from PALSAR-1 images of years 2007-

2010 or from PALSAR-2 images of years 2015-2016), all the steps in Chapter 0 have to be repeated. 

The reason for doing this is that the threshold for deforestation between years 2010 and 2015, which were from two 

different sensors (PALSAR-1 and PALSAR-2), may not be applicable for a different set of years, especially if the 

images are taken only by one sensor. 

  





E. Forest cover change classification, 
accuracy assessment and unbiased 
area estimation
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Just like the forest cover classification, the steps which are discussed in chapter C, decision tree classification is also 

the algorithm of choice for the forest cover change map. 

Additional post-classification steps are applied in order to delineate Deforestation areas that are not affected by 

radar effects and only occur in areas that were previously classified as forest. 

As also done in chapter C, if accuracy assessment samples are available then the process of accuracy assessment and 

unbiased area estimation are applied to the results of the maps. Chart 6, Annex 5 is a visualization of the process 

flow of this chapter. 

E.1 Forest cover change classification 
• Data required:  

o Georeferenced DCI image (product of D.1) 

o Thresholds for the decision tree classifier (product of D.4) 

• Software: ENVI 5.x (classic view) 

• Purpose: To generate a forest cover change map using the thresholds identified in the previous chapter. 

 

1. After the thresholds have been identified in D.4, decision tree classification can be done using the steps of C.6. 

 

The input image should be the DCI image and the thresholds for the decision tree classifier should be from D.4. 

Note: Avoid using the Class value zero (“0”) for the classes identified by the Decision Tree 

Classification. This is to prevent the mask, which usually has a value of zero, to be merged with the class that 

has a value of zero as well. 

E.2 Post-classification 
• Data required:  

o Forest cover change map (product of E.1) 

o Combined radar effects mask (second product of D.1) 

o Post-classified forest cover map of year 1 (product of C.7) 

• Software: ENVI 5.x (classic view) 

• Purpose: To obtain deforestation locations happening only in areas that have been initially identified as forest. 

 

1. Open ENVI 5.x (classic view) and the post-classified forest cover map of year 1 (product of C.7). The file 

will appear in the Available Bands List. Load the image into a Display. 

 

2. Build a mask for the forest areas by clicking on Basic Tools > Masking > Build mask… A Mask Definition 

window will prompt you to select an input display. 

 

Select Display#1 or the display on which you have opened the post-classified forest cover map of year 1 

(Step 1) and click OK.   
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This will automatically determine the number of Samples and Lines that you will work with. 

 

If you will choose “No Display”, you will need to determine the Samples and Lines manually before you can 

proceed to the next step. 

 

3. In the Mask Definition window, click on Options and make sure that the Selected Areas “On” option is 

checked then click on Import Data Range. 

 

4. The Build Mask Input File window will appear. Select the post-classified forest cover map of year 1 and click 

OK.  
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5. The Input for Data Range Mask window will appear. The Forest class has a DN value of “2” in the post-

classified output therefore, both the Data Min and Max Value will be 2 so that the mask produced will only 

contain areas with DN values of “2” or Forest. 

 

Note: The DN value may be different for your image, so please check first by applying Step 2 of C.9. When you 

are sure about the data range inputs, click on OK. 

 

6. Save the output if desired by selecting the radio button for File. Navigate to the location where you want to 

save the file and supply a filename. If you do not wish to save the file, just select the radio button for Memory. 

Click Apply to produce the forest mask for year 1. 

 

7. Open forest cover change map produced in the previous section (E.1) and the combined radar effects mask (second 

product of D.1). 
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8. Mask out the combined radar effects mask from the forest cover change map by clicking on Basic Tools > Masking > 

Apply mask…  

 

The Apply Mask Input file window will appear.  

Select the forest cover change map and click on Select Mask Band then select the combined radar effects 

mask as input. 

 

Click OK twice. 

 

9. The Apply Mask Parameters window will appear. 

 

The Mask Value should have a value of zero. Save the output if desired and click OK. 

 

The output will be the forest cover change map with areas of radar effects masked out.  
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10. Repeat Steps 7 and 8. The inputs should be as follows: 

 

Select Input File:  forest cover change map with areas of radar effects masked out (product of Step 9).  

 

Select Mask Input Band: Forest Mask for year 1 (product of Step 6). Result: deforestation occurring only 

within the forest areas of year1. 

 

11. Create a mask that contains only Deforestation pixels by repeating Steps 1 to 6. 

 

The input data will be the output of Step 10. The DN value of Deforestation is likely also “2”. Double check 

the DN value by applying Step 2 of C.9. 

 

12. Combine the following bands using Band Math: 

1) combined radar effects mask (second product of D.1), 

2) forest mask of year 1 (product of Step 6), and  

3) the deforestation mask (output of Step 11). 

To do this, click on Basic Tools > Band Math… 

 

The Band Math window will appear and in the Enter an expression box, type the expression “b1+b2+b3”. Click 

OK. 
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13. The Variable to Bands Pairings window will appear. 

 

Click on one variable (i.e. B1) from the Variables used in expression box and click on one available band (i.e. 

Forest Mask) in the Available Bands List box. 

 

One variable should correspond to one file/band. Type a location and filename if you would like to save the 

output. If you do not wish to save the output, select the radio button for Memory. Click OK.  
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The output will have 4 digital numbers (0-3). 

• 0 is mask 

• 1 is for land with no forest therefore also no deforestation (stable non-forests) 

• 2 for forest with no deforestation (stable forests) and 

• 3 for forest with deforestation (simply Deforestation areas). 

 

14. Do not close ENVI and proceed to the next section. 

E.3 Accuracy Assessment 
• Data required:  

o Post-classified image generated from E.2 

o Accuracy assessment shapefiles of Non-Forest from Chapter B. 

o Accuracy assessment shapefiles of Stable Forests and Deforestation from D.3 

• Software: ENVI 5.x (classic view) 

• Purpose: To calculate the accuracy of the generated change maps using ground truth samples/regions of 

interest (ROIs). 

 

1. A new file will appear in the Available Bands List after the last step of the previous section finishes. 

 

Load that band and you will see that the image that it produces is in gray scale. This is not a classification 

image, which is required by the accuracy assessment step. 

 

To convert the image into a classification image, click on Overlay>Density Slice… 

 

The Density Slice Band Choice window will appear. Select the file generated by E.2 and click OK. 

 

 

2. The #1 Density Slice window will appear. Hit the Clear Ranges button to clear the default ranges generated. 
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3. Click on Options > Add New Ranges… 

 

The Add Density Slice window will appear. Supply the data ranges as described in Step 13 of the previous 

section and change the color based on this information. 

 

4. When all the ranges have been filled in and corresponding colors have been assigned, the #1 Density Slice 

window will appear and look like the following image. 

 

Click on Apply and it will change the gray scale image into a colored image based on the density slices you have 

prepared. 
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5. To save this Density Slice to a Classification file/image, click on File > Output Ranges to Class Image… 

 

The Output Ranges to Class Image window will appear. 

 

Select the radio button for File and click on Choose to select the location of the new file. Type a filename and 

click OK. 

 

The new file will appear in your available bands list.  

 

6. Load the new file and click on Overlay > Classification… 

 

The Interactive Class Tool Input File window will appear. Select the file generated in Step 5 and click OK. The #2 

Interactive Class Tool window will appear.  
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7. In this window, you will see that the classes are named based on the density slices assigned in the previous 

steps. 

 

To change the names to the designated classes, click on Options > Edit class colors/names… 

 

The Class Color Map Editing window will appear. 

 

Click on a class below Selected Classes and change the Class Name. 
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8. After editing the class names of all the classes, click on OK. 

 

9. The #2 Interactive Class Tool window will appear. 

 

Click on File > Save Changes to File… An ENVI Question will appear. Click YES.  
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10. The #2 Interactive Class Tool window will remain open. You can close it and proceed to the next step. 

 

11. Repeat the steps of C.8. 

 

The input image is the output of Step 9. 

 

The shapefiles that will serve as accuracy assessment samples would be Non-Forest (from Chapter B), Stable 

Forests and Deforestation from D.3. 

E.4 Unbiased Area Estimation 
• Data required:  

o Classification image file generated from E.3 

o Confusion Matrix results from E.3 

• Pre-formatted spreadsheet: Unbiased Area Estimation (3 classes- Deforestation/Stable Forest/Non-Forest) 

• Software: ENVI 5.x (classic view) and MS Excel 

• Purpose: To calculate bias-free estimates of the Deforestation class. 

 

1. Repeat the steps of C.9. 

 

The input image should be the output of E.3. 

 

The confusion matrix results from E.3 are also required as input in the Unbiased Area Estimation 

spreadsheet that assesses three classes (Non-Forest, Stable Forests, and Deforestation). 

 

The steps of the entire Chapter E will be repeated for each DCI image if more than one AOI is being classified. 

If no accuracy assessment samples for Deforestation are available, then sections E.3 and E.4 cannot be done and the 

resulting maps will not be assessed for accuracy and unbiased estimates cannot be achieved.  
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Annex 1. Where and how to download the 25-meter mosaic datasets 

1. Users must register first through http://www.eorc.jaxa.jp/ALOS/en/palsar_fnf/registration.htm. Registration 

is free but an email check is sent to the registered email before a user can start downloading. Supply the 

required information as shown in the following image. 

 

2. Once a user has registered, proceed to the dataset download site: 

http://www.eorc.jaxa.jp/ALOS/en/palsar_fnf/data/index.htm. Type the email address that was registered 

in the previous step and input the password sent in the email. Note that the password cannot be changed. 

  

http://www.eorc.jaxa.jp/ALOS/en/palsar_fnf/registration.htm
http://www.eorc.jaxa.jp/ALOS/en/palsar_fnf/data/index.htm
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3. When the log-in is successful, 25-meter resolution products from JERS-1 and PALSAR-1/2 will be displayed. 

These can be downloaded by year. For the purpose of this manual, the PALSAR-1/ 2 mosaic data are needed, 

therefore select a year under PALSAR-1/2 to display the available data (i.e. year 2015). 

 

4. A global coverage of all the data for the chosen year will be shown.  

 

Select the grid containing your area of interest (AOI) (i.e. western-most part of Palawan, Philippines).  

 

The years on the top part of the page allow you to jump from one year to another.  

 

 

5. The area covered by the selected box will be zoomed in. To further see the 25-meter mosaic scenes, click on 

the grid containing your AOI. In this example, the western most part of Palawan is inside the grid N10 

E115.  
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6. The last grid is further divided into 25 grids/cells. Select the grid that corresponds to your desired AOI. If 

more than one grid covers the AOI, click on those grids/cells to download them as well. 

 

 

7. A new page will open when you click on a grid from the previous step. This now contains the download 

button. 

 

To download the PALSAR data, click on the Download button, highlighted by red box in following image. 
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8. This will prompt you where to save the compressed (‘.tar.gz’) file. Select a location and click Save. It is best 

not to change the nomenclature of the files so that all users can easily identify the files saved. 
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9. If the other areas of interest are part of a different year, repeat steps 4-8. Should you prefer mosaic data from 

other areas of the same year, use the “Back” button in the upper part of the page. Clicking on the Back button 

of the browser will bring you back to the global coverage as seen in Step 4. 
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Annex 2. How to Install RSGISLib 

1. Install VirtualBox and the Extension Pack. 

2. Run the VirtualBox and click on File > Import Appliance… 

3. The Import Virtual Appliance window will appear. Click on the icon at the end of the empty box to choose the 

virtual appliance that you will import. 

 

 

4. Navigate to the folder containing the RSGISLib open virtualization appliance (OVA) file. Click on that file 

and hit the Open button. 

 

5. The Import Virtual Appliance window will appear again. Click on Next. 
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6. The Appliance settings will appear. Click on import. 
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7. The Importing Appliance window will run. Wait for it to finish. 

 

 

8. The Xubuntu OVA will appear on the VirtualBox. Do not start it yet. 

 

9. Right click on the OVA and click on the Settings.  
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10. Under the General settings > Advanced > Drag’n’Drop select Bidirectional. 

 

11. Under the System settings > Motherboard, change the base memory depending on your computer. 
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12. Make sure that you will not allot more memory for the virtual machine than your host machine. An error will 

appear at the bottom if the settings you have selected is invalid. 

 

13. In the same System Settings, proceed to the Processor Tab and increase the CPUs to half of what is 

available in your computer. (i.e. 2 out of 4). 

 

14. Click on the Display Settings > Screen. 

 

Under the Video Memory, increase the allotted memory to your preference (ideally a little more than half of 

what is available).  

 

Click OK to accept all the changes in the settings. 
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15. Back to the main window of the VirtualBox Manger, click on Start to run the Virtual Machine. 

 

16. The Xubuntu_RSGISLib OVA will load. The time it will take to load and run depends on how powerful your 

machine is. 
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Annex 3. How to interpret the decision trees from R 

The following diagrams are sample outputs of the R script. 

The convention of the R script is that the left side agrees (YES) with the equality/expression being assessed and the 

right side disagrees (NO). 

The following sample decision tree is the threshold for LC1, which separates Land from Wetland/Flooded Crop. 

 

The thresholds in the boxes above can be omitted from the Decision Tree as both form a single class. 

It can be simplified as seen in the following image. 

 

The next decision tree is the threshold for LC2 which separates Vegetation from Settlement/Bare Soil (Sett/Bare 

Soil). 
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Similar to the decision tree for LC1, the thresholds in the big box of the LC2 decision tree can be omitted as these 

form a single class only (Vegetation – “Veg”). It can be simplified as shown in the following image. 

 

The last decision tree is the threshold for LC3 which separates Non-Forest (NF) from Forest (F) classes. 

 

Again, the thresholds in the two boxes of the LC3 decision tree can be omitted. It can be simplified as follows: 

 

If all the decision trees for LC1, LC2 and LC3 are combined, the joint decision tree will look like the following 

image: 
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Annex 4. Complete table that would be used by the R scripts 
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Annex 5. Flow charts 

Chart 1. Overall workflow of the study 
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Chart 2. Flow chart of the data preparation and pre-processing of radar remote sensing data 
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Chart 3. Flow chart of the sampling scheme and identification of samples for training and accuracy 

assessment 
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Chart 4. Flowchart of the forest cover sample analysis, actual forest cover classification, accuracy 

assessment and unbiased area estimation 

 

  



 
    

 
156 

 
 

Chart 5. Flowchart of the deforestation sample collection and analysis for forest cover change classification 
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Chart 6. Flowchart of the forest cover change classification, accuracy assessment and unbiased area 

estimation 
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